Alternative Format Statement
This publication is available in alternative media upon request.

Statement of Non-Discrimination
The Pennsylvania State University is committed to the policy that all persons shall have equal access to programs, facilities, admission, and employment without regard to personal characteristics not related to ability, performance, or qualifications as determined by University policy or by state or federal authorities. The Pennsylvania State University does not discriminate against any person because of age, ancestry, color, disability or handicap, national origin, race, religious creed, sex, sexual orientation, or veteran status. Direct all inquiries regarding the nondiscrimination policy to the Affirmative Action Director, The Pennsylvania State University, 328 Boucke Building, University Park, PA 16802-5901; tel. (814) 865-4700; TDD (814) 863-1150.
Objectives

✓ Become familiar with the Dreamweaver interface
✓ Customize Dreamweaver to suit your needs
✓ Define a local copy of your site for editing and management
✓ Create and edit text and horizontal rules
✓ Insert images, tables, and hyperlinks

Some considerations

Before you begin developing a Web site in any type of software application, it is best to determine the major sections/areas of the Web site you plan to create. Planning ahead will save you both time and assure that your Web site is easy to navigate for the end-user.

There are 5 major steps of designing a Web site. They are: Planning, Designing, Developing, Publishing, and Maintenance. These steps are outlined in the handout entitled “Web Reference Guide”. It can be downloaded from the Handouts & Resources section of the Training Services Web Site at: http://its.psu.edu/training/.

There are three key areas in developing an effective website: 1) audience appeal 2) ease of navigation and 3) richness of content.

When planning and designing your website, you need to take into consideration who your intended audience is. If the audience is an intended employer, then your website or e-portfolio will have a different feel and look from a website designed as a family or individual showcase. Remembering who you want your website or e-portfolio to appeal to is essential.

The second key is to make the site easy to navigate. You may want to consider using the “five click rule”. The five click rule is one in which we want the viewer to be able to find the information that they are looking for in five clicks of the mouse or fewer from the website homepage. A website that is confusing, poorly organized or difficult to find information in will lose the attention of the visitor very quickly.

The third key is to make the site as rich in content as possible. While flashy graphics may look great, they don’t always contain the information that the viewer is looking for. It may be better to sacrifice a flashy graphic for some good content that tells the audience the information you want them to know, rather than their having to guess at it.
The Dreamweaver Interface

- **Document window**, which displays the web page approximately as it will appear in a browser. This of course is very browser independent, so do not assume it is correct.

- **Panel groups** are sets of related panels grouped together under one heading. To expand a panel group, click the expander arrow at the left of the group’s name; to undock a panel group, drag the gripper at the left edge of the group’s title bar.

- **Property Inspector**, which displays all of the properties for a selected object in the document window. The property inspector changes to display the options available for each different object. Most every object will cause the property inspector to change its content. If you ever need to change something about an object, look here first!

- **The Files panel** enables you to manage your files and folders, whether they are part of a Dreamweaver site or on a remote server. The Files panel also enables you to access all the files on your local disk, much like Windows Explorer (Windows) or the Finder (Macintosh).

- **The Insert bar** contains buttons for inserting various types of "objects," such as images, tables, and layers, into a document. Each object is a piece of HTML code that allows you to set various attributes as you insert it. For example, you can insert a table by clicking the Table button in the Insert bar. If you prefer, you can insert objects using the Insert menu instead of the Insert bar.

- **The Document toolbar** contains buttons and pop-up menus that provide different views of the Document window (such as Design view and Code view), various viewing options, and some common operations such as previewing in a browser.
Most of the Dreamweaver palettes and options are only available on a per object basis. If you are not getting the options you expect, check to be sure you have the proper object selected.

Setting up a site

With Dreamweaver, you can easily build a web site on your local computer and then transfer it to a server. As you create your site, you should save files in folders, creating a structure that will make locating and adding files easier as the site grows.

The structure you choose on the local computer will transfer seamlessly to your server as long as things don’t move around in the transfer. Dreamweaver bases all links and paths on where the file is in relation to the “root” folder. You create a local root folder that corresponds to the site root on your remote server. If you work on more than one site, you can create additional local sites by choosing additional local root folders. When you transfer files between local and remote sites, Dreamweaver automatically maintains identical directory structures to ensure against accidental breaking of links and references. If folders do not exist on the site where files are being transferred, Dreamweaver automatically creates them.

As you work with Dreamweaver more, you will find some useful features for keeping the site up to date, including the ability to check files in and out, so that files are not being edited at the same time by different people, and a feature that lets Dreamweaver perform version control to remove files or folder on the remote site that no longer exist locally.
Defining your site

Every web site you work on must have a local place to build the site. To create or edit a site, you must go to the “Site” menu and select “Manage Sites”. The following window will open:

Choosing “New…” or “Edit…” will allow you to change any options associated with a particular site. When you select either of these buttons, the “Site Definition” dialog box appears. For most users, the Basic tab should be selected so that you can walk through the steps in establishing your website. For advanced users who wish to set up a testing server and control other protocols, the Advanced tab should be selected. In this illustration, the Basic tab is on the left and the Advanced tab is on the right.

The Site Definition dialog box allows you to define elements for five site management features. Of these five categories, the most important is the local information, which determines where your site is “built” on the local computer. Of course this could be a floppy, a network drive, a hard drive folder... whatever you want. Nothing in your website should ever be placed outside of this folder, as it will not be viewable on web servers, and it is not a recommended practice.
Please take note of the comments with the HTTP Address section and the Cache check box. These options are usually a good thing to have selected. Let us briefly discuss the other options in this window aside from “Remote Info.” Most of these options will have good default selections, but you should still know what each of them will do for you.

The Design Notes section allows you to decide if you desire to keep notes with each page. It is a separate file that Dreamweaver keeps with any web page you choose to add notes to. This is not something that will ever be viewable in a web site, but simply allows you to share information with fellow designers. You may choose to make notes on changes as they happen or keep a particular revision scheme with designers or even use this tool just to make notes to yourself. There is also an option for having Dreamweaver automatically upload your notes to the remote site when a file is updated and transferred.

Site Map Layout allows you to specify an “index” page for the site. This file will be used to determine how files are organized in the site map view of the site window. In site map view you can see the relationships of all your files to one another along with all of the files and links contained in each file.

File View Columns will let you choose the columns that you want to be visible in the site management window. You may want to “free up” space by eliminating some columns if you will not use them, such as “notes”. Take a look and see what you feel will be useful.

The Document Window: Creating Your Pages

Once you have created a site in the Site Window, you simply need to start adding files to the local root folder. To start a new document (HTML page):

Select “New Window” from the “File” menu of the site window or any document windows that may already be open. As an alternative you could use the key combination, “Ctrl-n”

This will begin a new page, properly started with the most basic HTML ready for you to start editing. If you have used any WYSIWYG editor before or even a basic word processor, the interface is relatively similar and rather intuitive.

For information on creating a page using a page template, please see page 12.
Once a blank document is opened, the first step is usually to set the global page settings, like the background color and/or graphic, the default font color, and what margins the page will have. These settings can be found in the “Page Properties” dialog box, under the “Modify” menu.

Here you can edit the basic page properties like page title, page wide colors and background images. However, you will also want to take notice of the following options:

Left/Top Margin and Margin Width/Height: These options both deal with the margin space inherent in most browsers, stopping content from ever actually reaching the edge. If set to zero, the browser will allow the page content to actually start at the edge of the window, or wherever your design calls for it to start. Each option, however, must be set to work with different browsers, as one refers to IE and one to Netscape.

Tracing Image: If your web development team has done a graphic mock up of the web site, you can place a copy of this image in the background of the page to use as a “template.” Select the image here and then decide on how “faded” you want it to be with the transparency setting.

**Entering Text**

Dreamweaver text editing is very similar to any other WYSIWYG editor. Dreamweaver can handle text from other sources, such as MS Word, other desktop applications, as well as text that you hand type in the design environment.

It is important to note that copying text from other sources may create formatting situations that are undesirable. It is always best to strip as much formatting as possible from copied text sources. There are several methods that you can use to bring “clean” text in to Dreamweaver. Although it does take some extra time to prepare text, it is usually much less time compared to reformatting the Web page in Dreamweaver. Dreamweaver offers several commands that allow you to convert MS Word generated HTML as well as text from other preformatted sources into cleaner text version. While the commands are automated and the tools are easy to use, it will not catch all of the formatting errors and style insertions.
The Property Inspector

The Property Inspector in Dreamweaver is your main editing tool. Every object in a document, whether a paragraph of text or an image, is modified through the options displayed in this tool. Depending on where your cursor is or what you currently have highlighted, will determine what this window looks like. In other words, this palette is dynamic. It changes with the content you are currently editing. The views we will see most today are:

<table>
<thead>
<tr>
<th>The Property Inspector- Common Views</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Format</strong></td>
</tr>
<tr>
<td>Font Default Font</td>
</tr>
</tbody>
</table>

**Character/Paragraph formatting**

**Image Formatting**

<table>
<thead>
<tr>
<th>Table ID</th>
<th>Rows</th>
<th>W</th>
<th>H</th>
<th>Cell Pad</th>
<th>Align</th>
<th>Default</th>
<th>Class</th>
<th>None</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Table Formatting**

<table>
<thead>
<tr>
<th>Format</th>
<th>Style</th>
<th>B</th>
<th>I</th>
<th>Link</th>
<th>Page Properties...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Font Default Font</td>
<td>Size None</td>
<td>Link Target</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Cell Formatting (bottom half)**

The Properties Inspector will appear look different depending on what you have selected in the document.
Using Objects

Every element you add to a Dreamweaver Web page is considered an object. Each object has a specific set of attributes that can be changed with, mostly via the Property Inspector. Although we will only be using the most commonly used objects in this class, you will quickly see that each object in Dreamweaver has a very simple dialog box interface for inserting and manipulating the object. Once we have had an opportunity to see how these common objects interact with the Property Inspector, we will begin the process of building a first page.

<table>
<thead>
<tr>
<th>Common Objects</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Image</td>
<td>The Image button does exactly what you would expect it to – insert an image. Pressing this button provides a file open dialog box. If there are any characteristics that can be changed with the image, they will become available in the Property Inspector when the picture is selected.</td>
</tr>
<tr>
<td>Rollover Image</td>
<td>The Rollover Image button will provide an interactive dialog box for choosing two images for an image rollover. You will give the combined image a name, determine if the images will be preloaded, and provide a URL for when the image is clicked.</td>
</tr>
<tr>
<td>Table</td>
<td>The Table button, like other object buttons, will provide a user friendly dialog box for entering the row and column specifications for a basic table including padding, spacing, width and border size.</td>
</tr>
<tr>
<td>Horizontal Rule</td>
<td>The Horizontal Rule button provides an interface for the horizontal rule in a web page. Make note that this button does not provide any dialog box for things like height and width.</td>
</tr>
<tr>
<td>Navigation</td>
<td>The Navigation Bar button is a helpful tool if you have made all of the images you need to create a graphical navigation bar. You can specify the direction of the navigational bar, whether it should be horizontal or vertical, and up to four images for every part of the navigation bar dependent on the position and action of the pointer. All JavaScript will be created for you once the process is done. Note: Although Dreamweaver appears to simply make the navigation bar and not treat it as a separate object, you can edit it later (apart from the table options) by using the “Modify Navigation Bar” option in the “Modify” menu.</td>
</tr>
<tr>
<td>Named Anchor</td>
<td>The Named Anchor button is the last button worth mentioning right now. Any time you want to place a <code>&lt;A NAME=&gt;</code> tag, this is the button you want to use. It will place an “invisible” marker at the place where it was inserted. This is the marker you use to link to with the “point-and-shoot” method when it comes time for that. Again, realize that many of these buttons are just a time saver. They may not do anything spectacular, but they will save you some code typing.</td>
</tr>
</tbody>
</table>

*Using the common object buttons is equivalent to using the commands through the menu bar.*
Create Documents Based on Page Designs

Page designs are pre-made Web pages that contain the most common Web page elements. If you are designing a new site, page designs are a great resource to get started.

1. To create a page based on a page design, select File from the menubar and click New...
2. With the General tab selected, select Page Designs from the Category area.
3. In the right hand column you will see a variety of pre-made page designs. Note that a preview and description of the page design is available in the Preview and Description areas respectively.
4. Select the design that you would like to use from the Page Designs area.
5. Click the Create button.
Using Snippets

Snippets are portions of HTML code that can be inserted into a document. Snippets are essentially parts of an overall page design and can be used in conjunction with new blank documents and page design starter pages.

Snippets are found in the Snippets panel (under Code), and they can be accessed through the Window menu bar item. Window → Snippets

To add a Snippet to a page you may drag the snippet on to the document or select the snippet then click the Insert button within the Snippet panel.

Using Style Sheets

Style sheets determine the appearance of text in the Web page. A style sheet file contains formatting characteristics of the document which can be applied to multiple pages within a Web site. Style sheets help to ensure formatting consistency from page to page. In addition, because these style sheets are based on CSS (Cascading Style Sheets), the formatting will also be more consistent from browser to browser, in other words, the pages will be more compatible.

Dreamweaver supports the creation of CSS and also has some pre-made style sheets, which are similar to page designs.

The process for creating a pre-made style sheet is very similar to using page designs.

1. To create a pre-made style sheet, select File from the menubar and then select New...
2. With the General tab selected, click CSS Style Sheets from the Category area. Note that you will see a preview and description of the style sheet in the Preview and Description areas respectively.
3. Select the style sheet that you would like to use from the CSS Style Sheets area.
4. Click the Create button.
5. The document will open and it will display the style sheet in a text editor view.

Now, we will save the file so that we can use it in our Web pages.

6. Select File → Save
7. Give the file a name. Do not include spaces or special characters.
8. Save the file in site folder. This file will be uploaded with your Web site when you publish.

Now that we have created the Web page and style sheet, we need to associate the two files so that the style sheet can control the text formatting of the HTML document.

9. Open the page that will have the style sheet attached.
10. Open the CSS Style panel. Choose Window → CSS Styles
11. Click the panel options button in the upper right corner.
12. Select Attach Style Sheet...
13. Select the style sheet file that you created earlier.
14. Save and preview the document.
Publishing with Site Window

Publishing with the site window, once you have some content is not difficult. The only thing you need to specify is how you will get content onto the remote site. This decision is reflected in the “Define Sites” dialog box. Go there and “edit” the site we created earlier. After selecting “Remote Info” on the left, you should see the following:

For the Penn State Personal server, the information that needs to be completed in the “Remote Info” category is listed above. Once the information is entered, you can return to the Site Window. Making the connection is easy, simply press the “Connect/Disconnect” button and Dreamweaver will handle the information transfer for you. When it is finished, you should see a top-level folder in the left hand window, and any other files that you have placed there. There are a lot of ways to make the local and remote location content match.

The simplest way is to select the “Synchronize” option from the “Site” menu. This will inspect each location for the newest copy of each file and then suggest changes. At this point, you can choose to select all of the files for replacement or individual files. Dreamweaver will do the rest of the file transfer for you.

Once a site is synchronized, you save changes to a file by “getting” and “putting”. Whenever you save a file, it saves locally. When the time comes to update the remote site, you can always select the synchronize option, user the put option to move individual files. If there are any elements associated with a particular file, Dreamweaver will ask you if you want to copy those as well. If they already exist and are not any more recent than remote files, nothing will be copied to save time.

Setting preferences

Dreamweaver has a very extensive area for setting specific preferences that will adjust the programs behavior to suite your needs. When you first start using Dreamweaver, there are just a few that are recommended to allow the program to function well “out of the box.”.
When you open Dreamweaver, go to EDIT – PREFERENCES to set or change these preferences. When the preferences dialog box opens, you will see a list of categories on the left. If it is not selected, click on General.

General

Make sure that the checkbox for “Show start page” is checked in the Document Options area.

Preview in Browser

Dreamweaver allows you to set up to 12 Web browsers that you can use to preview your HTML document in. Setting them up in the “Preview in Browser” category simply allows you to select a browser from within Dreamweaver to preview a temporary copy of your Web page. Simply put, it’s a convenience. To add a new browser to this category you click on the plus symbol and find the program on your hard drive. If you are going to be doing Web design that is professional in quality, you should always design to the lowest common denominator, which at this point is Netscape 4.7. Therefore, you should have a copy of Netscape 4.7 and Internet Explorer 5.5 for previewing your documents.

Invisible Elements

The third category to be aware of as you begin to use Dreamweaver is “Invisible Elements.” This category allows you to make viewable or to hide the symbols that Dreamweaver uses to show where “hidden” elements of your Web page are located. There are often good reasons for having these symbols appear, but at times, they can distort the visual appearance of a document inside of the Dreamweaver window because the symbols actually take up space in the window, something that would not happen in a Web browser.
Resources

**ITS Training Services**
Training Services Web Site: [http://its.psu.edu/training/](http://its.psu.edu/training/)
Free Seminar Handouts on the Web: [http://its.psu.edu/training/resources/handouts/](http://its.psu.edu/training/resources/handouts/)
Web-Based Training: [http://wbt.psu.edu/](http://wbt.psu.edu/)

**Penn State Help Resources**
University Learning Centers: [http://www.ulc.psu.edu/](http://www.ulc.psu.edu/)
Help Desk: [http://css.its.psu.edu/consulting/](http://css.its.psu.edu/consulting/)
Faculty Multimedia Center: [http://tlt.its.psu.edu/fmc/](http://tlt.its.psu.edu/fmc/)